MyBundlePay - USD Virtual Card API Funds Resolution – Incident details

App ( Android & IOS ) under maintenance

USD Virtual Card API Funds Resolution

Resolved
Operational
Started 5 months agoLasted 4 months

Affected

Website

Partial outage from 6:00 PM to 5:19 PM

Updates
  • Resolved
    Resolved

    Service Update: USD Wallet Restoration Completed

    We’re pleased to inform you that the reconciliation of USD wallet balances affected during the recent Virtual Card API upgrade has been successfully completed. All impacted funds have now been fully restored.

    The Virtual Card API service is operating normally, and users can continue funding their USD wallets, issuing virtual cards, and managing transactions without any disruption.

    We sincerely appreciate your patience and continued trust as we work to maintain a stable, secure, and reliable platform.

    — The MyBundlePay Team

  • Identified
    Identified

    We’re currently resolving previous USD wallet funds affected during the recent virtual card API upgrade. Our team is actively reconciling and restoring all impacted balances.

    In the meantime, users can continue using the Virtual Card API service by funding their USD wallets anew and proceeding to issue and manage virtual cards as normal.

    We sincerely appreciate your patience and understanding as we finalize this process to ensure full balance restoration and improved service stability.

    — The MyBundlePay Team